My vncserver cannot work! Expect your hel p!

awoiwo@126.com awoiwo "at" 126.com
Mon Jan 8 05:40:00 2007


Some infos about my os:
root "at" ia641 bin]# uname -a
Linux ia641 2.6.9-22.EL #1 SMP Mon Sep 19 17:54:55 EDT 2005 ia64 ia64 ia64 GNU/Linux

***************************************************************************************************************
I download a free RealVNC copy from WWW:
-rw-r--r--  1 globus globus   1659360 Dec 22 05:51 vnc-4_1_2-x86_linux[1].tar.gz
-rw-r--r--  1 globus globus   1602052 Dec 31 16:00 vnc-4_1_2-x86_linux.rpm
***************************************************************************************************************
When i attempt to install the rpm packet, the following error appears:
[root "at" ia641 portal]# rpm -ivh vnc-4_1_2-x86_linux.rpm 
error: Failed dependencies:
        ld-linux.so.2 is needed by vnc-4.1.2-1.i386
        libc.so.6 is needed by vnc-4.1.2-1.i386
        libdl.so.2 is needed by vnc-4.1.2-1.i386
        libICE.so.6 is needed by vnc-4.1.2-1.i386
       libSM.so.6 is needed by vnc-4.1.2-1.i386
        libstdc++-libc6.2-2.so.3 is needed by vnc-4.1.2-1.i386
        libX11.so.6 is needed by vnc-4.1.2-1.i386
        libXext.so.6 is needed by vnc-4.1.2-1.i386
        libXtst.so.6 is needed by vnc-4.1.2-1.i386
        libc.so.6(GLIBC_2.0) is needed by vnc-4.1.2-1.i386
        libc.so.6(GLIBC_2.1) is needed by vnc-4.1.2-1.i386
        libc.so.6(GLIBC_2.1.3) is needed by vnc-4.1.2-1.i386
        libc.so.6(GLIBC_2.2) is needed by vnc-4.1.2-1.i386
        libm.so.6(GLIBC_2.0) is needed by vnc-4.1.2-1.i386  libm.so.6 is needed by vnc-4.1.2-1.i386

***************************************************************************************************************
So i install the "vnc-4_1_2-x86_linux[1].tar.gz" according the readme file.
***************************************************************************************************************
but.....................vncserver cannot work :
[root "at" ia644 ~]# vncserver
 
New 'ia644:1 (root)' desktop is ia644:1
 
Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/ia644:1.log
 
[root "at" ia644 ~]# cat /root/.vnc/ia644\:1.log 
sh: /usr/local/bin/Xvnc: cannot execute binary file
xsetroot:  unable to open display 'ia644:1'
/root/.vnc/xstartup: line 10: /usr/local/bin/vncconfig: cannot execute binary file
Warning: This program is an suid-root program or is being run by the root user.
The full text of the error or warning message cannot be safely formatted
in this environment. You may get a more descriptive message by running the
program as a non-root user or by removing the suid bit on the executable.
xterm Xt error: Can't open display: %s
 
(gnome-session:8662): Gtk-WARNING **: cannot open display:  
***************************************************************************************************************
Why??........." sh: /usr/local/bin/Xvnc: cannot execute binary file"  ,I don't why because:         
[root "at" ia641 portal]# cd /usr/bin
[root "at" ia641 bin]# ls -al |grep Xvnc
-rwxrwxr-x   1 root root    2306931 May 13  2006 Xvnc
 
###############################################################################
Expect your help! Any tips would be apreciate!!! Thanks in advance!